Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 1
 
 
Reply with quote Download Post 
Post Broke My ACP - Blank With Two Errors Up Top ... 
 
Here's all I did so far ...

First, I had my site all set up today and was happy.  After a few of my friends posting threads and helping me check things out, I finally decided I was ready to delete the initial "Test" forum and category that come with the install.

That broke my entire site (ACP and regular) causing a blank white page on both.

I searched the forums like every good noob should do, and found the solution of deleting everything in /cache/ except htaccess and index.  I did so and the site was working fine again.

I went to the ACP to continue customizing my new site and suddenly my ACP does not work.  It is a blank white screen with the following errors:
Code: [Download] [Hide] [Select]
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 2997: readdir(): supplied argument is not a valid Directory resource
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 3012: closedir(): supplied argument is not a valid Directory resource


The site still works fine.  I went and re-did all my CHMODs just in case.  But now I am stuck as to what to do.
 



 
tbird412Send private messageVisit poster's website  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
I'm definitely not one to give great suggestions when it comes to coding, but you could always give this a try.  Backup your current /includes/functions.php file first and place it somewhere safe.  Now upload a new, fresh copy of functions.php to your server.  As always, be sure to clear the entire cache.

If that doesn't work, we'll see what some other guys suggest here.
 




____________
| Icy Phoenix ColorizeIt! |
Bipolar Disorder - Not good for you and definitely not good for everyone else.
 
ChaoticSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
Re-uploaded the file .... cleared all the files in /cache/ again except for htaccess and index ....

Still no good.  Still get a blank white page with this error when trying to go to my ACP:
Code: [Download] [Hide] [Select]
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 2997: readdir(): supplied argument is not a valid Directory resource
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 3012: closedir(): supplied argument is not a valid Directory resource


EXTRA:  Just in case it helps any, here's what I get from "View Source" of the page itself (maybe see how far in the code it gets before an error.  But appears to get nowhere)
Code: [Download] [Hide] [Select]
<b>[Icy Phoenix Debug] PHP Notice</b>: in file <b>/includes/functions.php</b> on line <b>2997</b>: <b>readdir(): supplied argument is not a valid Directory resource</b><br />
<b>[Icy Phoenix Debug] PHP Notice</b>: in file <b>/includes/functions.php</b> on line <b>3012</b>: <b>closedir(): supplied argument is not a valid Directory resource</b><br />

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html dir="">
<head>
<!-- IE conditional comments: http://msdn.microsoft.com/workshop/author/dhtml/overview/ccomment_ovw.asp -->
<!--[if IE]>
<style type="text/css">
/* IE hack to emulate the :hover & :focus pseudo-classes - Add the selectors below that required the extra attributes */
.row1h, .row1h-new { behavior: url("http://www.blackknightsclan.org/templates/common/pseudo-hover.htc"); }
</style>
<![endif]-->
<title>Icy Phoenix Administration</title>
<meta http-equiv="Content-Type" content="text/html;">
<link rel="stylesheet" href="../templates/common/ACP.css" type="text/css" />
<link rel="shortcut icon" href="../images/favicon.ico">
</head>
<frameset rows="45px,*" frameborder="no" framespacing="0">
    <frame src="ip_header.php?sid=322f7f56aa8c71edb0b16a7417ad6c37" scrolling="no">
    <frameset cols="200,*" border="2" framespacing="0" frameborder="yes">
        <frame src="index.php?pane=left&amp;sid=322f7f56aa8c71edb0b16a7417ad6c37" name="nav" marginwidth="3" marginheight="3" scrolling="auto">

        <frame src="index.php?pane=right&amp;sid=322f7f56aa8c71edb0b16a7417ad6c37" name="main" marginwidth="10" marginheight="10" scrolling="auto">
    </frameset>
</frameset>
<noframes><body bgcolor="#FFFFFF" text="#000000"><p>Sorry, your browser doesn't seem to support frames</p></body></noframes>
</html>

 



 
tbird412Send private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
Just ensure that you are uploading all of the files in binary and NOT ascii, and don't chmod anything unless the install script tells you that something is not readable or writeable.


 
 
 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
Yes and yes
 



 
tbird412Send private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
I am assuming you are emptying your cache file manually instead of using the cache options in the ACP...

if  yes then you deleted some important folders from the cache folder....

you need to delete your cache folder from your server and upload a fresh one from the download from this site...

you should then be able to login to your ACP and delete the cache using the link under CONFIGURATION/CLEAR CACHE

As you are using RC1 careful when reading older topics as a lot of the code has changed in this version...

hope that helps

   
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
DWho, you are a god!  I freaking love you.
 



 
tbird412Send private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
tbird412 wrote: [View Post]
DWho, you are a god!  I freaking love you.


   

I guess it is working....

   
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Broke My ACP - Blank With Two Errors Up Top ... 
 
Sure is!  And the more I dig deeper into IP the more I love it.  This is incredible.  Why is this guy not charging?  I would have easily paid $100 for something like this.

Thanks though DWho.  You've solved every problem I have had.  If I ever go to the UK again I'll buy you a beer.  Though I doubt I will go back to England.  That place really messed me up last time
 



 
tbird412Send private messageVisit poster's website  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 1
 


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events


  

 

  cron