Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 1
 
 
Reply with quote Download Post 
Post Please Help: Need To Update Database Schema From Old Ip Version 
 
Greetings,

I am laboriously working to upgrade a IP board with near 200 users and several thousand posts, from: IP Version 1.1.0.15 and phpbb2 version 2.0.22 to: IP 1.2.24.51 RC2. As to the new phpbb version that the current IP is running on, I've no idea as it is not displayed anywhere that I can see.

Regardless, I am seeing many schema differences in the database. I have been able to successfully import the ip_users, and ip_categories tables, and recreated the ip_forums table through the CMS webapp; however, in order to import the ip_posts I am going to have to reconcile many differences in the table and an unknown number of dependencies in other tables.

Is there any any guidance on performing this upgrade? Or, conversely, is there a chain of schema upgrades that I can run through to incrementally upgrade the database through several stages and arrive at the current version of IP?

This upgrade is precipitated by the need to move this site from a shared hosting environment to a dedicated server that I have provisioned. I never was given root access, or any shell access for that matter, to the original server. I had only ftp access and phpmyadmin access. I was able to get the sysadmins for the box to create a tar.bz2 file of the DocumentRoot, as well as to dump the mysql db manualy, as I was not able to either transfer the content via ftp properly, nor get an error free download of the database as I experienced query timeouts through phpmyadmin. Due to this inability to direclty access the original server, I have been hampered in trouble shooting why I have been unable to simply move the site, in its exiting version, its current server to this new one. The errors with the original server's code and schema, on my new server, are all related to the variable $phpbb_root_path being null on a myriad include and include_once calls as per: h**p://***.ethericwarriors.org/ip (if you could check this out please). I read the PHPBB module developers guide, where one is instructed to define this variable on all user accessible files however, I find it missing in many, many, files on this old version. How it runs correctly, at the original site (which is still up) at h**p://***.ethericwarriors.com/ip is a mystery to me.

One point, the new server is running on OpenBSD 4.5 and the Apache 1.3 is chrooted so as to protect the server in the event of a compromise; however, I don't believe this is any issue as the new version of IP runs fine at: h**p://dev.ethericwarriors.org/ip

What I need to do is either to immediately move forward to transfering the data from the original site and move dev.ethericwarriors.org to production or, conversely, to succeed in bringing up the old code, on the new server, without errors and then, over time, port over to the new code.

Any help in this matter would be greatly appreciated

Thanks in advance.
 



 
ctellecheaSend private message  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Please Help: Need To Update Database Schema From Old Ip Version 
 
Ok, some progress. I have manged to find and fix the cause of the errors for the old IP code. For some reason, a few files did not include, within function a global definition of the variable $phpbb_root_path and therefore './' was not being prepended to the paths to code to be included via include and include_once calls within those functions. The errors are now gone from ***.ethericwarriors.org.

However, I still want to upgrade to the latest IP code, and to do so I need to port over the original database content and reconcile the schema changes. Whether it is MG (Mighty Gorgon) or somebody else, please let me know if there are any tools, documents, or any other advice to facilitate this.

Thanks
 



 
ctellecheaSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Please Help: Need To Update Database Schema From Old Ip Version 
 
in the install folder that comes with the download of RC2 there is an update file that allows you to update from all old versions of ICy... just remember to back up your old database...

In the docs section there is also a written guide on upgrading and installing...

Hope that helps ..


   
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Please Help: Need To Update Database Schema From Old Ip Version 
 
Even a copy is included on the /docs/ folder of your release.

BTW, FYI the upgrade script should upgrade the DB with no loss of data, unless you have made any changes on it.

As long as all the versions right now are based over phpbb 2.0.23 and phpbb dev team has dropped development and support on them, and there will be no releases of phpbb 2 series on the future, we only have a link to the phpbb site. At least I guess so.

PS: Do not try to go to phpbb.com website regardering IP support. It is so modded that they would give you any.
 



 
novice programmerSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Please Help: Need To Update Database Schema From Old Ip Version 
 
theres been a post from somebody who had the same problems. even Lopalong had a lot of problems upgrading from .27 to RC2.

the DB went in the shitter he said. theres been a lot of problems in that update-file


Lopalong wrote: [View Post]
I owe you an apology Daniel for suggesting that you did it the wrong way, because I also tried to upgrade RC1 to RC2 and it all went bad with the same errors you had, plus a few extra.  

But unlike you, I can't be bothered fixing them and may wait until I see what the next final release pans out to be, and how much Official Support it gets.

 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 1
 


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events


  

 

  cron