Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 2
Goto page 1, 2  Next
 
Reply with quote Download Post 
Post Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
On 18 July 2009, I installed Icy on my server.

On 16 August 2009, I asked "spydie" to assist me and show me how to do certain things and I allowed him access to my computer with a program that I use called, "Teamviewer".  Spydie was reluctant but agreed to assist and show me some tips, etc. on how to move forums. During the process, the website crashed and a blank page displayed for the site. In the status bar, it stated, "Done".

The only recourse was to contact the server and ask for help. They restored the database and files for me. All was ok.

On 26 August 2009, I finally felt comfortable that all was ok and so I made my first attempt (since 16 Aug 09) to move a newly created forum to a different category and the same thing happened to me.

The website crashed and I had to seek the help and assistance from my server host again. They are presently working to get the site up again.

Is this a known problem with ICY along with the other problems that I can not seem to get to work, ie.,

    * Mass Email by Admin to a specific group from the ACP: http://www.icyphoenix.com/viewtopic.php?f=2&t=6279
    * RSS Feed (Show only the topic in the Feed): http://www.icyphoenix.com/viewtopic.php?f=2&t=6333



Thank you for your timely response ( I Hope),

Dave
 




____________
Another Pro Bono
Version of Icy Phoenix: 1.3.0.53a
Version of PHP: 5.2.9
Version of MySQL: 5.0.81-community-log
Board started: 2009/07/18 - 11:50
Registered Users: 123 as of 17 Sep 09
 
Last edited by christmanrd on Thu 27 Aug, 2009 13:09; edited 2 times in total 
christmanrdSend private messageVisit poster's website  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
Just would like to point something out.

The process was executed like all of us do.

just went to move forum, selected another categorie for it and pressed submit.

Afterwards  the site went blanc.

Really wonder about this, because it never happend to me on my sites.

And i use the same process ( think there´s only this one)
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
@ Dave,

Mate, Icy Phoenix is a WIP and the Guys are doing the best they can with the information that they can gain by only experiencing the same problems themselves and working it out the best they can.

There are no Quick Fixes, and if anything MG would be the only one to remedy most of the problems that IP throws up, because HE is the ONLY one that fully understands what the hell is going wrong with the script / code etc because he is the sole programmer of what is a hybrid of phpbb2 and 3.

So downtime and answers can vary on how often MG attends this site, or keeps track of by subscription etc.

I wish I had some answers for you - But I don't

Maybe Icy Phoenix is not really what you want, and it's licensed forum software that  has all of the features that you do want and has been tried and tested with all sorts of mods and plugins etc.


 
 
 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
the trouble is... that from what i understand there have been code changes done to your site... i do not know who.. or what you have done...

but a blank page can be caused by a huge number of reasons... if you edit any files always always back up that file first so if you do make any changes and you receive a blank page you can instantly restore your site to what it was....

Never ever update a live site with files that you have changed till you tested them on your local computer... use Xampp or wamp for a complete test server that you can play around with...

When you contacted your host.. did you asked what caused the problem as they have logs on their server...

This problem has never happened on a standard icy package as it has been thoroughly tested to its limits...

its is

A) server configuration

B) user fault... eg files not uploading correctly or code being edited wrong...

When you hear back form your host please let us know what they say the problem is and then we maybe able to assist further

   


christmanrd wrote: [View Post]


    * Mass Email by Admin to a specific group from the ACP: http://www.icyphoenix.com/viewtopic.php?f=2&t=6279
    * RSS Feed (Show only the topic in the Feed): http://www.icyphoenix.com/viewtopic.php?f=2&t=6333



reagrding these issues... you are asking for someone to rewrite the standard code to fit your needs... please remember this is a voluntary site.. and if people have time they will try to help... but if you want it quickly... you might need to find someone who charges to do it....

though I believe the first issue MG has sorted out for you and will release it in the next patch....

Sorry i can not be of any more help...
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
I did´nt do any code changes there.

All files been edited , if by someone, by christmanrd himself.

Edit:

All i can say is, and y told him to do backup´s before any changes,

Quote:
"spydie" wrote:
Have you made a backup in the last day´s ??? Answer:  NOOOOOOO!


MAKE SHURE, YOU UPLOAD ONLY IN BINARY MOD OF YOUR FTP-CLIENT
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
Here is the discussion between my hosting service and myself.  

Quote:
    

Posted On: 27 Aug 2009 07:46 AM

Hi,

I don't see any issues with your website script code, and database connection is also working properly, and database blaircou_bctp is 4.5BM in size so it is not empty, also all the files appear to be there.

This could indicated that your website scripts are corrupted, you should check this further with your script developer as they should be able to provide more information about the issue.

Please let us know if you have any further questions.

Greetings,
Robert S.


Quote:

R David Christman     
    
Posted On: 27 Aug 2009 07:56 AM

Is there a log that you can look at to see what happened at the time this went haywire? If there is will you share that with me so I can tell the script people?

Thanks,



Quote:
Hi,

unfortunately such things are not logged, we basically only need a pointer from script developers so we know waht should we look for if the script is corrupted, so we can check further.

Please let us know if you have any further questions.

Greetings,
Robert S.


The only file that I did any changing with was the nav_quick_links.tpl which DWho corrected for me and it was placed back up on the server.

Hope this helps.
 




____________
Another Pro Bono
Version of Icy Phoenix: 1.3.0.53a
Version of PHP: 5.2.9
Version of MySQL: 5.0.81-community-log
Board started: 2009/07/18 - 11:50
Registered Users: 123 as of 17 Sep 09
 
christmanrdSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
couple of questions is this a new install or did you upgrade...?

do you have a blank page all over site...

did you chmodded all the files that need it

have you done a search here for similar problems that might help..

your are definitely using version 1.3

what php are you using on your server...

what host are you using

go into cpanel and check you error logs ... copy them here so we can see what is going on
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
It´s deffinatly IP 1.3

I´ve just been thinking of what the problem might be.

He did that changes without locking the site. Could be that a user or MOD been changing or posting something the same time and the DB just went crazy about that.

Anyway the site is up and running again. Hoster restored to a backup from yesterday


But i would like to know MG´s opinion about this threat
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
I'm not buying into who should do what etc, other than to say that it is the responsibility of the Webmaster to make sufficient backups of his site before making any changes.

I know we have the attitude that "This is only a small change, so what could go wrong"?

The script below has either been edited using an editor that is NOT suitable or it has been uploaded using the WRONG format. And if it was PHP, it would be fatal and no doubt would be the cause of "White Pages" amongst all other things it could generate.

And that's all it takes - One lousy Quick Edit - That won't go wrong?  

BTW Dave - This is not from your site.  

<!-- INCLUDE overall_inc_footer.tpl --> <tr>     <td colspan="3">     <div id="bottom_logo_ext">     {IMG_TBL}     <div id="bottom_logo">         <table class="empty-table" width="100%" cellspacing="0" cellpadding="0" border="0">             <tr>                 <td nowrap="nowrap" class="min250" align="left"><span class="copyright">{COPYRIGHT_LINK}{TRANSLATION_INFO}</span></td>                 <td nowrap="nowrap" align="center">                     <div style="text-align: center;">                         <span class="generation"><b>{LOFI}</b></span><br />                         <!-- IF S_GENERATION_TIME -->                         <span class="generation">{PAGE_GEN_TIME} <b>{GENERATION_TIME}s</b> (PHP: {PHP_PART}% SQL: {SQL_PART}%){MEMORY_USAGE}</span><br />                         <span class="generation">{SQL_QUERIES}: {NUMBER_QUERIES} - {DEBUG_TEXT} - {GZIP_TEXT}</span>                         <!-- ENDIF -->                     </div>                 </td>                 <td nowrap="nowrap" class="min250" align="right">{TEMPLATE_COPYRIGHT_LINK}</td>             </tr>         </table>     </div>     {IMG_TBR}     </div>     </td> </tr> </table> {PAGE_END}  {BOTTOM_HTML_BLOCK} <span><a name="bottom"></a></span> <!-- IF not S_BOT -->{RUN_CRON_TASK}<!-- ENDIF -->  </div>  {GOOGLE_ANALYTICS} </body> </html>

I'm also not saying that this is your problem - I'm only pointing out how easy it is to "Break" something.
 
 
 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
Aug 30, 2009, 10:10am EST Update.

This am at appoximately 09:20 EST, I locked my site, created a back up and proceeded to re-organize my forums.

I tired to delete a  forum, and the site crashed again.

My hosting is in the process of restoring my db and files for the 3d time in what a week?


Aug 30, 2009, 10:40am EST Update.

My Hosting Provider is asking these questions.  My answers are in italics.

Quote:
Dave,

Your php script isn't running from shell either, I am not sure what this script you ran was supposed to do however it appears to have either changed your database or your files in a manner that causing them to fail.

  • Do you have a location where this script is working? I don't have another location where I run this script.
  • What is this script supposed to do exactly?  This is a Fourm.  Is that what you are asking?  It is (if I am not mistaken based on phpbb.)
  • Are there any server settings that we should investigate? I really do not know.
  • Have you been able to contact the developers of the script? No, I am trying to communicate with the developers support team at the present time.


Regards,
James



Aug 30, 2009, 12:07pm EST Update.

I presently have a redirect page site up stating, Site Under Maintenance.  I went to www.blaircountyteaparty.org/index1.php  which is the normal index.php with a name change and I received the following:


Critical Error

Error doing DB query userdata row fetch

DEBUG MODE

SQL Error : 1194 Table 's' is marked as crashed and should be repaired

SELECT u.*, s.* FROM ip_sessions s, ip_users u WHERE s.session_id = '05e8a027946c6ced7cb628db68e46e72' AND u.user_id = s.session_user_id AND session_time > 1251644775

Line : 446
File : sessions.php
 




____________
Another Pro Bono
Version of Icy Phoenix: 1.3.0.53a
Version of PHP: 5.2.9
Version of MySQL: 5.0.81-community-log
Board started: 2009/07/18 - 11:50
Registered Users: 123 as of 17 Sep 09
 
christmanrdSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
i think that the problem is server related.

just tried to go to your site and i found this message

Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1194 Table 'ip_config' is marked as crashed and should be repaired

SELECT * FROM ip_config

Line : 344
File : common.php


anybody got an idea

Well look´s like it´s up and running again.

would be nice to have a look at the servers error log´s.

because one thing is shure. this only happens when you try to do something at the forum managment, like move or delete a forum.
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
@ Dave,

PM MG with a link to your latest post as I think we need this looked at from the 'highest Level"
 
 
 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
Funny thing is that MG has been around the forum the time Dave posted this.

Maybe he just don´t had the time to go through all new messages and topic´s
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
Dave, I understand the trouble you are going through. I wanted to test moving the forums in forum management, and found the same difficulty. I did find one thing that was happening.

Even with my server (host), there is an issue that prevents the forum_cat mysql table from being updated with the new information.

I was able to duplicate the problem with my site. Each time the only way I got it back up, was to "restore database" with my host.  With my host there is a function to restore any database to a recent previous state.

I looked at the Forums cat mysql data, and for some reason, data was not totally written to the file when you move a forum.

Hope this helps those better at finding mysql problems......

By the way, my site is restored each time, and my host is the key.

 
 




____________
My main IP 1.3 site
My IP 1.3 styles test site
 
gearheadSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Icy Phoenix 1.3.0.53 - WEBSITE CRASH 
 
maybe MG should know about this.

Because or the problem is server related ( witch i´m nearly shure it is) , or it´s a script problem ( what i don´t believe , because your the only ones, having this problem, at least who posted the problem)

BTW:

both of you should upload info.php (file is attached). call up the file ,

and post the hole data from that file here in a spoiler. so maybe we can find the function that is not installed or running incorect, and you can call your hoster to ask them to install (activate) that function.

info.rar
Description:  
Download
Filename: info.rar
Filesize: 155 Bytes
Downloaded: 43 Time(s)

 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 2
Goto page 1, 2  Next


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events


  

 

  cron