Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 1
 
 
Reply with quote Download Post 
Post Posting Problem 
 
Hi Guys,

              I have upgraded my site to the new version (1.3..0.53) now everything works apart from when members post,  when you click the submit button you get the below message

Code: [Download] [Hide] [Select]
Parse error: syntax error, unexpected T_STRING in /home/sites/uk-alliance.com/public_html/includes/emailer.php(225) : eval()'d code on line 3
[Icy Phoenix Debug] PHP Notice: in file /posting.php on line 1324: Cannot modify header information - headers already sent by (output started at /includes/emailer.php(225) : eval()'d code:3)
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 1236: Cannot modify header information - headers already sent by (output started at /includes/emailer.php(225) : eval()'d code:3)




any ideas ??
 



 
n1cks21Send private messageVisit poster's website  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Posting Problem 
 
It seems that your server is not escaping slashes correctly.

Which version of PHP do you have?

Do you have a phpinfo() page where I can check your settings?
 




____________
Luca
SEARCH is the quickest way to get support.
Icy Phoenix ColorizeIt - CustomIcy - HON
 
Mighty GorgonSend private messageSend e-mail to userVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
I seem to have fixed the posting problem by reinstalling the sql database however I still have a problem with slashes as you pointed out below is some text from my home page and you can see how IP has added lots of slashes, now if I delete them and save it they come back

Code: [Download] [Hide] [Select]
<div align=\\\"center\\\">
<b><font size=\\\"7\\\"><font color=\\\"Red\\\">WELCOME TO THE UK-ALLIANCE</font></font></b></p>
<p align=\\\"center\\\"> </p>
<p align=\\\"center\\\"> </p>
<font size=\\\"4\\\">The ONLY UK adult clan that plays for fun,


here is the link you asked for http://www.uk-alliance.com/phpinfo.php

thanks again
 



 
n1cks21Send private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
Unfortunately there is not an easy way to solve it now.

Try this though.

OPEN common.php
FIND
Code: [Download] [Hide] [Select]
while ($row = $db->sql_fetchrow($result))
{
    $board_config[$row['config_name']] = $row['config_value'];
}

REPLACE WITH
Code: [Download] [Hide] [Select]
while ($row = $db->sql_fetchrow($result))
{
    $board_config[$row['config_name']] = stripslashes($row['config_value']);
}



But you will need to edit again your text fields in ACP => Configuration, because this fix is not able to fix already entered texts.

And I'm not sure it will work properly for you.
 




____________
Luca
SEARCH is the quickest way to get support.
Icy Phoenix ColorizeIt - CustomIcy - HON
 
Mighty GorgonSend private messageSend e-mail to userVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
replace with:
Code: [Download] [Hide]
  1. while ($row = $db->sql_fetchrow($result))  
  2. {  
  3.     $board_config[$row['config_name']] = stripslashes($row['config_value']);  

 



 
InformproSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
Thanks for looking but I am still having the same problem

as you can see from image 1

error1

if I enter "The UK-Alliance, gaming at it's best......." in the Site description and save it I get this result.....

error2
 



 
n1cks21Send private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
That is because you need also to edit admin_board*.php and add stripslashes there as well...

FIND
Code: [Download] [Hide] [Select]
$new[$config_name] = (isset($_POST[$config_name])) ? $_POST[$config_name] : $default_config[$config_name];


REPLACE WITH
Code: [Download] [Hide] [Select]
$new[$config_name] = (isset($_POST[$config_name])) ? $_POST[$config_name] : stripslashes($default_config[$config_name]);

 




____________
Luca
SEARCH is the quickest way to get support.
Icy Phoenix ColorizeIt - CustomIcy - HON
 
Mighty GorgonSend private messageSend e-mail to userVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Posting Problem 
 
still the same      
 



 
n1cks21Send private messageVisit poster's website  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 1
 


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events


  

 

  cron