Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 2
Goto page 1, 2  Next
 
Reply with quote Download Post 
Post Hacking Attempt Error When Trying To Upgrade... 
 
Hello,

I was running 1.2.0.27c (i believe) and trying to upgrade to 1.3.0.53a.

Here is my upgrade screen after having done the update.  Had an error the first time, but i thought it got fixed in another step:

Quote:
Server And Version Information


Installed phpBB version :: 2.0.23 » Latest release :: 2.0.23
Installed Icy Phoenix version :: 1.3.0.53a » Latest release :: 1.3.0.53a
Database Type :: mysql4
File Writing :: Your server doesn't support file creation and editing.
Files & Folders Permissions:
Spoiler: [ Show ]
Spoiler: [ Hide ]
CHMOD 777

../backup  
../cache  
../cache/forums  
../cache/posts  
../cache/sql  
../cache/topics  
../cache/users  
../ctracker/logfiles/logfile_attempt_counter.txt  
../ctracker/logfiles/logfile_blocklist.txt  
../ctracker/logfiles/logfile_debug_mode.txt  
../ctracker/logfiles/logfile_malformed_logins.txt  
../ctracker/logfiles/logfile_spammer.txt  
../ctracker/logfiles/logfile_worms.txt  
../downloads  
../files  
../files/album  
../files/album/cache  
../files/album/med_cache  
../files/album/users  
../files/album/wm_cache  
../files/posted_images  
../files/screenshots  
../files/thumbs  
../images/avatars  
../logs




But when I try to go to the site, it's just a white screen with Hacking Attempt!

I can't get anywhere with it at the moment....in the process of restoring old files and restoring the old DB and going to try it from the beginning again and see what happens.  If anyone has any clue though I would appreciate it.

EDIT:  Restored the old files, but can't figure out how to restore the DB without IP....and when i try to go to my site, i get this error now

Quote:
Critical Error

Could not query portal layout information

DEBUG MODE

SQL Error : 1054 Unknown column 'forum_wide' in 'field list'

SELECT template, forum_wide, view, groups FROM ip_cms_layout WHERE lid = '1'

Line : 79
File : index.php


EDIT 2:
UPDATE:  I was thinking....I did have the medal mod installed and didn't update changed files by the patch.  Would that have something to do with it??

I just updated the chanfged files and am going to try this....ill post and let you know.

EDIT 3: Didn't work....still getting Hacking attempt error
 



 
Pyro-TechSend private message  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
Any hacking attempt you see on your site basically means you still have old files still installed somewhere...

have you checked your ctracker folder I have found that if you have forgotten to copy over the new files into this folder you are more than likely to receive a hacking attempt displayed n your screen.

   
 




____________
Mods and themes for Icy Phoenix 1.3

IcyPhoenix UK is off-line permanently due to lack of time to update mods.
if anyone is interested in my templates I will upgrade them to Icy 2.0.
 
DWhoSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
The question is .

Did you use the full install package or the .53a patch.

If you use only the patch. Icy would´nt work and through this errors.

A patch is´nt a full install package
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
I didn't realize that you couldn't use the patch file to upgrade....i just assumed.  I saw the instructions on the full download and had a "doh" moment.

So now I got my site restored and gonna try it again.

Question though....should I upload clean and upgrade then install mods or do mods and install/upgrade in one go??

I have the medal's mod installed on my current board.
 



 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
first do the upgrade, check that everything works, and when start modding.

Medal Mod for 1.3 was posted here somewhere
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
spydie wrote: [View Post]
first do the upgrade, check that everything works, and when start modding.

Medal Mod for 1.3 was posted here somewhere


yeah i saw it.

did they fix the issue with hotmail users and the verification e-mail??

EDIT also on the install instructions from upgrading from older IP....

Remove the following folders (make sure you don't have in those folders some files you may need for some mods you have installed, but in any case you should have a backup ):
adm
includes
language
templates

is this in my root or the 1.3 install files?  it's a little vague.

EDIT 2: i'm getting some errors with the MySQL database_update.php

Quote:
•INSERT INTO `ip_config` (config_name, config_value) VALUES ('link_this_topic', '0')
+++ Error: Duplicate entry 'link_this_topic' for key 1


•ALTER TABLE `ip_cms_blocks` ADD `border` TINYINT(1) SET DEFAULT '1' AFTER `border_explain`
+++ Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SET DEFAULT '1' AFTER `border_explain`' at line 1


•ALTER TABLE `ip_cms_blocks` ADD `titlebar` TINYINT(1) SET DEFAULT '1' AFTER `border`
+++ Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SET DEFAULT '1' AFTER `border`' at line 1


•UPDATE `ip_cms_blocks` SET border= '0' WHERE border_explain= '0,0,0,0'
+++ Error: Unknown column 'border_explain' in 'where clause'


•UPDATE `ip_cms_blocks` SET border= '1' WHERE border_explain= '1,1,1,1'
+++ Error: Unknown column 'border_explain' in 'where clause'


•UPDATE `ip_cms_blocks` SET titlebar= '0' WHERE titlebar_explain= '0,0'
+++ Error: Unknown column 'titlebar_explain' in 'where clause'


•UPDATE `ip_cms_blocks` SET titlebar= '1' WHERE titlebar_explain= '1,1'
+++ Error: Unknown column 'titlebar_explain' in 'where clause'


•ALTER TABLE ip_registration_desc DROP `reg_option1`
+++ Error: Can't DROP 'reg_option1'; check that column/key exists


•ALTER TABLE ip_registration_desc DROP `reg_option2`
+++ Error: Can't DROP 'reg_option2'; check that column/key exists


•ALTER TABLE ip_registration_desc DROP `reg_option3`
+++ Error: Can't DROP 'reg_option3'; check that column/key exists


•INSERT INTO ip_config VALUES ('ip_version', '1.3.0.53a')
+++ Error: Duplicate entry 'ip_version' for key 1


normal??
 



 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
Don´t care about this errors.

they happend to me aswell.

and that files are in your root.

first delet them , and then upload the new ones.
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
Ok so I'm at the point where I'm supposed to run the install/install.php but only thing I'm seeing is an "Internet Explorer cannot display webpage" screen.

Any thoughts?

EDIT:  I am going to attempt to re-upload the files....i saw the issue somewhere about the upload not being binary and I don't know how to check that within SmartFTP so I'm doing a manual upload through my provider's ftp.  I'll be back in a moment and let ya know how that goes.

EDIT 2: So i re-uploaded and tried again, got this error first and then goes back to doing the IE can't display...

Quote:
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_ct_config_472022be091812506f0b3d47818afb38.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_config_3ba19af46892e3453550c70fc489cba0.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_cms_config_3b39877871bc3473aa67cc04801b7aef.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_attach_f82dfb867587d92cbdb4646606bf0262.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/sessions.php on line 499: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2016)
[Icy Phoenix Debug] PHP Notice: in file /includes/sessions.php on line 500: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2016)
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_word_censor_0d69f94172b8f8bdae5714116b0e76cb.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/forums/sql_forums_cats_4646f1e205eb9b2819189d0db3e3429d.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/forums/sql_forums_6f0592fdf89c869f7d0437cd6a462c55.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_moderators_825f7f2bb2bf13c691a46dd6dd5e558a.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_moderators_5c071ee6e48bebf50b52c8dbe2636c76.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/posts/sql_posts_9c0c21b2de78c2e51da0211afa310144.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/posts/sql_posts_5dd4a89c8c0e974569b379273e20b929.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/db/mysql.php on line 817: fopen(./../cache/sql/sql_themes_6470ed106a92cb1fdabaaec1a2b122f7.php) [function.fopen]: failed to open stream: Permission denied
[Icy Phoenix Debug] PHP Notice: in file /includes/functions.php on line 1224: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2016)


I noticed when i re-upped, i had to redo my CHMOD and that's when it went back to doing a blank screen

EDIT 3:  I noticed that if i try to go to the database_update.php, it will come up just fine...and if i type just the install folder, i can get an Icy Phoenix link to show.....but anything else and it dies
 



 
Last edited by Pyro-Tech on Sun 31 Jan, 2010 00:44; edited 1 time in total 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
It looks like url_fopen is´nt enabled on your host.

give this a try.

Upload the adjectend file to your root, and see if it helps.


Edit.

I hope you did keep the original config.php from your old version in your root

php.rar
Description:  
Download
Filename: php.rar
Filesize: 551 Bytes
Downloaded: 43 Time(s)

 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
The root of my whole web directory or the root of IP??

I tried both and it's still same screen

EDIT: Yes my original config is in there.  I think those errors were due to not being CHMOD correctly...it went back to doing blank after having redone the CHMOD parts
 



 
Last edited by Pyro-Tech on Sun 31 Jan, 2010 00:53; edited 1 time in total 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
question.

can you post a link to your site please, so i can have a look
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
http://darkspace.darkwindonline.org

I thought it was earlier in the thread....sorry bout that  

EDIT:  I also have MSN if that would be any easier for work/communication to be done....if not then that's fine too
 



 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
Ok

try this.

Open common.php

find:
Code: [Download] [Hide] [Select]
include(IP_ROOT_PATH . 'config.' . PHP_EXT);

if(!defined('IP_INSTALLED') && !defined('IN_INSTALL'))
{
    header('Location: ' . IP_ROOT_PATH . 'install/install.' . PHP_EXT);
    exit;
}

include(IP_ROOT_PATH . 'includes/constants.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/template.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/sessions.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/auth.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/functions.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/functions_categories_hierarchy.' . PHP_EXT);


replace with:
Code: [Download] [Hide] [Select]
include(IP_ROOT_PATH . 'config.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/constants.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/template.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/sessions.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/auth.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/functions.' . PHP_EXT);
include(IP_ROOT_PATH . 'includes/functions_categories_hierarchy.' . PHP_EXT);


this worked for me. that stops endless redirecting
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
ok that lets me get by the looping....but i haven't done the install portion yet and it wants me to delete the install and contrib folders

I don't even have a contrib folder for that matter
 



 
Pyro-TechSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Hacking Attempt Error When Trying To Upgrade... 
 
contrib folder is inside install

BTW. reupload the install folder and then type in http://darkspace.darkwindonline.org/install/install.php

that gets you back to your install menu. Now go through all steps
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 2
Goto page 1, 2  Next


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events