Icy Phoenix

     
 


Post new topic  Reply to topic 
Page 1 of 1
 
 
Reply with quote Download Post 
Post Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
I just upgraded (not completely) my site at http://haynesville.org/ from 1.2.0.27c (I think) to 1.3.0.53.a. I downloaded the full package and followed the instructions for upgrade. After I upload my previous config file, when I ran http://haynesville.org/install/database_update.php phpbb was first upgraded then the database tables were upgrade and the ended at the menu showing the my phpbb version was up to date and my IP version was up to date as can bee seen at the above mention link.

I uploaded the files in binary mode using Filezilla and change all of the required folder and files permissions which can also be confirmed at the above mentioned link.

Now when I try to go to anywhere, but http://haynesville.org/install/database_update.php I am redirected to http://haynesville.org/phpBB2/login...all/install.php although I do not have a phbb2 subdirectory between the domain root and ip. I install ip in the domain root directory. Any ideas on how to stop this redirect? Also is am I supposed to run the install.php script again after doing the database_update.php script?
 



 
flabbergastedSend private message  
Back to topPage bottom
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us
 
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
http://www.icyphoenix.com/viewtopic.php?f=2&t=6901

And yes your soposed to run install.php again, since that changes a lot of things in your DB, like fixing paths of images etc
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
Thanks for the reply spydie, but that didn't do the trick. I read that solution earlier and checked for the code then. (For some reason I didn't find it then.   ) What I can't figure out is why the redirect is adding the phpbb2 directory between the domain root and the ip root. Actually, the ip root and the domain root are one and the same.

Any other suggestions?
 



 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
yes.

Reupload the install folder.

maybe something not clean.

I hope you been logged in when you started the install
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
OK, I re-uploaded the install directory and changed the name to installation. I now get a page the has a white background, and has the menus across the top as links not buttons. There is also a message across the middle of the page that says, "Please ensure both the install/ and contrib/ directories are deleted". I am still not able to run the installation.

I am able to go to the home page, but it appears there are just a couple of images and some links. The login was available so I thought I would try to log in again. I was logged in when I started the upgrade, so I could disable the site. Now when I try to login, I keep getting a wrong password message. When I click on forgot password, I am told that NONE of my email addresses match the one on record for that user name. I only have some nay domains and I know what all of my email address are. If the installation script would run, it would probable finish the install and fix everything else. (I hope.)

UpDate: I once again deleted and upload the install directory and now it is back to what it was doing the first time. In other words, I am not even getting what I mentioned in the above paragraph. This is changing from one upload to the next.
 



 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
OK, my site has been down for about three days now. If anyone has any suggestions to fix this I would really appreciate it. No matter what page I go to I end up at the same place and none of the graphics are loading. Also most of the links include the subdirectory phpbb2 in the url which goes to a page not found message. Removing the phpbb2 portion of the url results in the same page loading at any of the addresses. I have NOT been able to run the install script after the database update script. Apparently I am no longer logged in as I keep getting redirected to a login in address, but there is no means of logging in.
 



 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
It has been 6 days since my last post. Does nobody here have any ideas about how to fix this problem?
 



 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
me to  have post more than 15 days (and more) without reply.
Have patience  

honestly I have no idea how fix your problem!!!
but also the problem of low participation, the last time, by the people who know well IP
 



 
CostaSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
I think you have to change something in your DB.
Looks like the path is wrong.

EDIT: Take a look in phpmyadmin ip_config and script_path

There should be only a /

I think you have /phpBB2/
 




____________
TheSteffen
Often SEARCH is the quickest way to get support.
IcyPhoenix German Support
 
TheSteffenSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
I did a search in all of the tables in the database for /phpBB2/ and it appears as a "Word or Value" in once in the table phpbb_config and twice in table phpbb_hacks. I do not know what the hacks table is for, but I figured the config table must be the controlling value. So I clickled on the edit button in phpMyAdmin and had to go to the third page of the listed table rows    to find the value for script path. I then clicked on the edit button and change to value from /phpBB2/ to / as indicated by TheSteffen.

This did make a change for the better. Thanks, TheSteffen. That solve one of my problems.

Now when I go to /install/install.php I am redirected to http://haynesville.org/login_ip.php...all/install.php . I think this is because I am no longer logged in, OR the install actually completed. I do not know which. When I click on login, I end up at the page thats says "Please ensure both the install/ and contrib/ directories are deleted".

I will delete these directories and update the progress.

UPDATE: Apparently all of the data was deleted when the database was upgraded. I am attempting to restore from the backup I made. Will this require that I do the database upgrade again?
 



 
Last edited by flabbergasted on Sat 27 Feb, 2010 01:40; edited 1 time in total 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
Great I could help you with one thing.

If you rename your install folder to maybe install_x

Can you than login as ADMIN (main admin) and also login in ACP?

After that rename install_x back to install
and Run install/install.php
 




____________
TheSteffen
Often SEARCH is the quickest way to get support.
IcyPhoenix German Support
 
TheSteffenSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
OK, here is the result of my update.

All of my data was deleted. I had backed up my database through phpmyadmin, but apparently I only backed up the database structure and not the data. So when I could not run the install script, I dropped all of my tables and import the backup file to return my database to where it was before the upgrade. After I imported the database again, I ran the database_update.php script again successfully doing the upgrade. So now I have a site with no data, just like starting a new on. The problem now is, the site loads with the user who owns the hosting account, but there is no way to log into the site. I tried setting a password in phpmyadmin, but I am still not able to login. At this point since all of my data was deleted, I might as well run this as a new install since I cannot log in to run the install script when IP thinks there is a database already setup with a user who can login. As long as IP thinks there is a user who can login I will not be able to run the install script.

In any case the site was set back to the beginning before the first member signed up. I will have to get some data in this and run a backup on it before I upgrade my other sites. I have almost 200 members on one and over a hundred on another and do not want to foul those sites up.
 



 
flabbergastedSend private message  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
just reupload a clean config.php

empty the database of tables, and run install again.

no need to reupload everything.

Try to check out, if your hosting has got a backup of your DB previos to update. that might help aswell
 




____________
Out of Order
 
spydieSend private messageVisit poster's website  
Back to topPage bottom
Reply with quote Download Post 
Post Re: Redirect Adding Phpbb2 Subdirectory Under Domain Root 
 
OK, I deleted all of the tables in the database and ran the install script which went fine. Now None of the pages will load. When I re-uploaded the install directory after deleting it as instructed after the installation, I am taken to a page with a message telloing me that both php and ip are up to date. Any page I try to go to now is timing out. (I hope my other upgrades go more smoothly than this. )

BTW, I did check in the database and the script path is correct. Permissions are correct also. I also know the database names, username and password are correct since the new database tables were created.
 



 
flabbergastedSend private message  
Back to topPage bottom
Post new topic  Reply to topic  Page 1 of 1
 


Display posts from previous:    

HideWas this topic useful?

Link this topic
URL
BBCode
HTML




 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You cannot attach files
You can download files
You cannot post calendar events