Icy Phoenix

     
 

RSS Language Problem...

RSS Language Problem...

Article
Reply with quote    Download Post  
Post RSS Language Problem... 
 
Hello again...

My forums native language is Greek.

The problem is that rss feed are displayed such as " ÂãÜëôå ÷ñÞìáôá ìå ëßãá êëéê ôç ìÝñá ! "

The setting at languge files are

Quote:
$lang['ENCODING'] = 'ISO-8859-7';
//$lang['ENCODING'] = 'UTF-8';
$lang['ENCODING_ALT'] = 'ISO-8859-7';
$lang['DIRECTION'] = 'ltr';
$lang['HEADER_LANG'] = 'en-gb';
$lang['HEADER_XML_LANG'] = 'en-gb';


I also changed the value in ACP>News Configuration>Feed Language > iso-8859-7

Is this a database encoding problem?
How can i fix it?
Thank you !

EDIT...

My todays configuration is

Quote:
$lang['ENCODING'] = 'ISO-8859-7';
//$lang['ENCODING'] = 'UTF-8';
$lang['ENCODING_ALT'] = 'ISO-8859-7';
$lang['DIRECTION'] = 'ltr';
$lang['HEADER_LANG'] = 'el-GR';
$lang['HEADER_XML_LANG'] = 'el-GR';


and in ACP>News Configuration>Feed Language > utf-8

Results: Topic title is shown in greek but content is unundarstandable likeΓ�Γ£Γ�ëôΓ₯ Γ·Γ±Γ�ìÑôÑ Γ¬Γ₯ Γ«Γ�ãÑ ΓͺëéΓͺ ôç Γ¬Γ�Γ±Γ‘ !


Please help me....



 
borbo - View user's profile Send private message  
borbo [ Wed 10 Mar, 2010 02:46 ]
Icy Phoenix is an open source project, you can show your appreciation and support future development by donating to the project.

Support us


RSS Language Problem...

Comments
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
Somebody Pleaaaaase?



 
borbo - View user's profile Send private message  
borbo [ Thu 11 Mar, 2010 14:17 ]
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
υπομονή .....


patience ..... LOL



 
Costa - View user's profile Send private message  
Costa [ Thu 11 Mar, 2010 20:11 ]
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
Any suggestion guys? Please ??? Why topic title is displayed correctly and topic content is not??

Any ideas?



 
borbo - View user's profile Send private message  
borbo [ Mon 15 Mar, 2010 00:37 ]
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
Sorry, but I can't help with this.

Next version should be full UTF-8 so these kind of issues should be easily to solve.

I have no time to develop a fix for Icy Phoenix 1.3 as it is not easy and it is time consuming.



 
Mighty Gorgon - View user's profile Send private message  
Mighty Gorgon [ Thu 25 Mar, 2010 11:47 ]
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
Thanks for the reply MG....Waiting to update !!



 
borbo - View user's profile Send private message  
borbo [ Sun 28 Mar, 2010 18:34 ]
Reply with quote    Download Post  
Post Re: RSS Language Problem... 
 
If your DB charset is set to UTF-8, if you set your lang charset to UTF-8 in lang_main_settings, then you can try to do this:

OPEN rss.php
FIND
Code: [Download] [Hide] [Select]
            $topic_title = utf8_encode($topic_title);
            $post_subject = utf8_encode($post_subject);
            $message = utf8_encode($message);


Remove all utf8_encode from there...

I am not sure that it will work fine... but you can try.



 
Mighty Gorgon - View user's profile Send private message  
Mighty Gorgon [ Fri 02 Apr, 2010 10:00 ]
Display posts from previous:    

HideWas this topic useful?

Post new topic  Reply to topic  Page 1 of 1
 
 




 


 

  cron